Let's continue the conversation


Support

Please use the buttons below to narrow your support query:
Using iFamily
Trouble Purchasing iFamily
Common Problems
Updating
OSX Versions
Version Change Log

Stuck?

Check out the forums

Send us an email.

Compatibility with OSX Versions


If you are upgrading your OSX version, it is recommended to use "Download Latest Release..." from the iFamily Menus before doing so.

If you have a version of iFamily for Tiger prior to V2.285 then you must upgrade it if you want to use it on Leopard.
If you have a version of iFamily for Leopard prior to V2.511 then you must upgrade it if you want to use it on Snow Leopard.
If you have a version of iFamily for Leopard prior to V2.522 then you must upgrade it if you want to use it on Lion.

If you have recently installed Leopard, Snow Leoaprd or Lion OSX and iFamily has stopped working, please contact us to send you a link, or alternatively access it from this link to the members section of the iFamily Support Forums.

Contact Us - Forums - Demo